We are currently unable to receive client calls due to a third-party issue. This is being worked on with the highest priority.

Incident Report for myPOS

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 13:12 UTC

Monitoring

myPOS Customer service have started to receive calls from Clients again and are closely monitoring the service stability.
Posted Oct 20, 2025 - 09:32 UTC

Investigating

We are currently investigating this issue.
Posted Oct 20, 2025 - 09:03 UTC
This incident affected: Customer Service.