Degraded Connectivity with myPOS Devices

Incident Report for myPOS

Resolved

This incident has been resolved.
Posted Sep 13, 2026 - 14:31 UTC

Monitoring

A fix has been implemented, and we are currently monitoring the system as traffic levels continue to increase. We will continue observing the situation to ensure that services remain stable.
Posted Sep 13, 2026 - 13:22 UTC

Update

We are continuing to work on a solution to this issue.

In the meantime, you can connect your POS device to a Wi‑Fi network. Alternatively, you can use the myPOS Glass app, available for iOS and Android - note that different fees may apply based on the selected plan.
Posted Sep 13, 2026 - 12:01 UTC

Update

We are continuing to work on a solution to this issue.

In the meantime, you can connect your POS device to a Wi‑Fi network. Alternatively, you can use the myPOS Glass app, available for iOS and Android - note that different fees may apply based on the selected plan.
Posted Sep 13, 2026 - 11:01 UTC

Update

We are continuing to work on a fix for the issue.

In the meantime, please be advised that you can connect your POS device via Wi‑Fi. Alternatively, you can download the myPOS Glass application, which is available for both iOS and Android devices.
Posted Sep 13, 2026 - 10:02 UTC

Update

We are continuing to work on a fix for the issue. In the meantime, please be advised that you can connect your POS device via Wi-Fi.
Posted Sep 13, 2026 - 06:12 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 13, 2026 - 05:43 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 13, 2026 - 04:15 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 13, 2026 - 02:10 UTC

Update

We are continuing to investigate this issue.
Posted Sep 13, 2026 - 01:49 UTC

Investigating

We are currently investigating this issue.
Posted Sep 13, 2026 - 00:49 UTC

Identified

We are currently investigating this issue.
Posted Sep 12, 2026 - 23:33 UTC
This incident affected: POS device payments.