Issue with Mobile application.

Incident Report for myPOS

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 18:00 UTC

Update

We are continuing to investigate this issue.
Posted Nov 21, 2025 - 16:54 UTC

Investigating

We are currently experiencing an issue with the mobile app. Our team is working with the highest priority to restore normal operations as soon as possible.
Posted Nov 21, 2025 - 15:32 UTC
This incident affected: myPOS Mobile Apps.