Maintenance of myPOS Glass application.

Incident Report for myPOS

Resolved

The scheduled maintenance for the myPOS Glass application has been successfully completed. All services are now fully operational. Thank you for your patience.
Posted Nov 18, 2025 - 08:29 UTC

Investigating

We are currently investigating this issue.
Posted Nov 18, 2025 - 07:22 UTC
This incident affected: myPOS Glass payments.