Third-Party Provider Service Degradation

Incident Report for myPOS

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 14:46 UTC

Investigating

We are currently investigating this issue.
Posted Nov 18, 2025 - 12:10 UTC
This incident affected: Online payments (Online checkout, Payment tag, Virtual terminal, Payment request) and myPOS Website, myPOS Mobile Apps.